rofi-pass with otp type support
This commit is contained in:
commit
c1cf7e4760
2
rofi-pass/.gitignore
vendored
Normal file
2
rofi-pass/.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
*.pkg.tar.zst
|
||||||
|
*.tar.gz
|
23
rofi-pass/PKGBUILD
Normal file
23
rofi-pass/PKGBUILD
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
|
||||||
|
# Contributor: Lex Black <autumn-wind at web dot de>
|
||||||
|
|
||||||
|
pkgname=rofi-pass
|
||||||
|
pkgver=2.0.2
|
||||||
|
pkgrel=3
|
||||||
|
pkgdesc="bash script to handle pass storages in a convenient way"
|
||||||
|
arch=('any')
|
||||||
|
url='https://github.com/carnager/rofi-pass'
|
||||||
|
license=('GPL')
|
||||||
|
depends=('xdg-utils' 'rofi' 'gawk' 'pass' 'pwgen' 'xdotool' 'xclip')
|
||||||
|
optdepends=('pass-otp: for OTP support')
|
||||||
|
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/carnager/${pkgname}/archive/${pkgver}.tar.gz rofi-pass.patch)
|
||||||
|
sha512sums=('28f59696911089c31b3f17bde281e3d79c3f757ecc4da61386719c6cff9b31c0944a2ac549d7838f06c249d4535c0dc107ba684115f15db42a24bfdb2f575437'
|
||||||
|
'd04dd33cec5d0d3ff4589877ced9286d57b7ff718e4af3554fb6fffafa04073a737dc2d9de5a405e51e65621d16f1c3af4f9dd2bde54ece3e3c4786660b0ee38')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
patch -i rofi-pass.patch "${srcdir}/${pkgname}-${pkgver}/rofi-pass"
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
make -C "${pkgname}-${pkgver}" DESTDIR="$pkgdir" PREFIX="/usr" install
|
||||||
|
}
|
26
rofi-pass/rofi-pass.patch
Normal file
26
rofi-pass/rofi-pass.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
--- src/rofi-pass-2.0.2/rofi-pass 2019-01-18 18:45:15.000000000 +0100
|
||||||
|
+++ rofi-pass 2022-07-08 09:49:54.901625307 +0200
|
||||||
|
@@ -342,6 +342,7 @@
|
||||||
|
-kb-custom-9 "${type_menu}"
|
||||||
|
-kb-custom-10 "${previous_root}"
|
||||||
|
-kb-custom-11 "${next_root}"
|
||||||
|
+ -kb-custom-12 "${type_otp}"
|
||||||
|
-kb-custom-14 "${action_menu}"
|
||||||
|
-kb-custom-15 "${copy_menu}"
|
||||||
|
-kb-custom-16 "${help}"
|
||||||
|
@@ -442,6 +443,7 @@
|
||||||
|
16) viewEntry;;
|
||||||
|
17) copyURL;;
|
||||||
|
18) default_do="menu" typeMenu;;
|
||||||
|
+ 21) sleep $wait; typefield=OTP; typeField;;
|
||||||
|
23) actionMenu;;
|
||||||
|
24) copyMenu;;
|
||||||
|
27) insertPass;;
|
||||||
|
@@ -465,6 +467,7 @@
|
||||||
|
printf '%s' "${autotype}: Autotype
|
||||||
|
${type_user}: Type Username
|
||||||
|
${type_pass}: Type Password
|
||||||
|
+ ${type_otp}: Type OTP
|
||||||
|
${qrcode}: Generate and display qrcode
|
||||||
|
---
|
||||||
|
${copy_name}: Copy Username
|
Loading…
Reference in New Issue
Block a user